PDA

View Full Version : PropTool crash "Address Violation"



hippy
01-31-2008, 11:18 PM
Win XP SP2, PropTool 1.06

"Address violation at address 00000000. Read of address 00000000"

Maybe it's the way I'm working but I'm seeing quite a few of these in recent days. I've tried to find a guaranteed way to cause the crash but no luck so far, but I can see some a common theme -

Two source files open ( so a left and right tab shown )
Source in right tab not edited
Source in right tab has text highlighted and copied
Source in left tab selected
Paste in copied text, more edits, F9 compile tests, save the file
Switch to right tab ( text there still highlighted )
Right-click to bring up pop-up menu
Click "close"
>>Splat<<

It doesn't happen if the above is done immediately after starting the PropTool but it does after working with the left tab for a longer period ( edits, cuts, pastes, F9's, saves ) and once the "Address violation" occurs, opening a second tab and the above steps seem to make it repeatable on demand.

Thankfully it hasn't so far closed the PropTool and lost any work which hasn't been saved.

Rayman
01-31-2008, 11:27 PM
Do you have removable drives (like memory card reader)? I get a ton of error messages like that while starting the Prop tool because of mine...

Oldbitcollector (Jeff)
01-31-2008, 11:34 PM
Ray, Try this.. It solved the issue of errors because of empty card interfaces.





1. Click Start and then Run.
2. Type REGEDIT into the Run dialog box when it comes up and then click OK. The Registry Editor will open.
3. Navigate to and select the following key:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Contro l\Windows

4. On the right pane, right click on "ErrorMode" and click on Modify.
5. Change the value to 2.




OBC

▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔
New to the Propeller?

Getting started with the Protoboard? - Propeller Cookbook (http://ucontroller.com/Propeller%20Protoboard%20Designs%20for%20the%20Beg inner.pdf)
Got an SD card? - PropDOS (http://www.orrtech.net/propdos/)
A Living Propeller FAQ - The Propeller Wiki (http://propeller.wikispaces.com/)
(Got the Knowledge? Got a Moment? Add something today!)

Rayman
01-31-2008, 11:55 PM
I think I'm afraid to do that! Besides, that's XP right? Not sure it the same on this Vista x64 box...

Oldbitcollector (Jeff)
02-01-2008, 12:06 AM
Yes it's XP.. Not sure what Vista will do, perhaps I'll test it and see if there are ill effects the next time I load Vista in my shop.

OBC

▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔
New to the Propeller?

Getting started with the Protoboard? - Propeller Cookbook (http://ucontroller.com/Propeller%20Protoboard%20Designs%20for%20the%20Beg inner.pdf)
Got an SD card? - PropDOS (http://www.orrtech.net/propdos/)
A Living Propeller FAQ - The Propeller Wiki (http://propeller.wikispaces.com/)
(Got the Knowledge? Got a Moment? Add something today!)

hippy
02-01-2008, 02:14 AM
In my case no removable media at all, except DVD and whatever XP supports in-built as per USB.

That it doesn't do it all the time ( only on close, and even then not always ) and from the actual error it does look like a standard 'null pointer exception'.

Jeff Martin
02-01-2008, 05:33 AM
Thanks hippy,

You've given me what I need to duplicate this (I think... haven't tried just yet).· I appreciate it.

And, yes, it looks like a null pointer, probably one pointing to an object that I'm manually destroying but that was "unknowingly" automatically destroyed by another object.· I'm glad to hear it isn't a fatal issue, but I will try to track it down shortly.

▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔
--Jeff Martin

· Sr. Software Engineer
· Parallax, Inc.

hippy
02-01-2008, 08:22 AM
Thanks Jeff. If it's any help to narrow it down ...

New, same fiddling about as above but don't save right tab
Return to right tab ( text highlighted still )
Click close, "Do you want to save ... ?"
No

"Address violation at address 7C918FEA in 'ntdll.dll'. Write of Address 00000010"

godzich
10-16-2008, 12:20 AM
Hi,

Just to BUMP this already old thread, and ask the question again - has this error been resolved (Access violation at·address 0000000: Read of address 0000000)???

IS there a planned schedule for publishing a propeller tool upgrade, and a new revision of the propeller manual?

This error·occurs to me quite frequently, especially after long edit sessions (> 2hours). It's a nuisance, but does not stop me from writing code...

regards,

Christian

Edit: I'm on XP 32 bit, SP3 - and the error occurs mainly when closing the application..

·

▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔
The future does not exist - we must invent it!

Post Edited (godzich) : 10/16/2008 7:25:44 AM GMT

CarlosFandango
10-16-2008, 03:08 AM
While this subject is being discussed, I have a similar (at least related) problem. I sometimes get the attached error when starting proptool, I think because at some point I had an SD card attached to my PC but have since removed it. But I can't find out how to clear the recent files list in proptool... is there a way of doing this? Clicking 'continue' a few times gets everything going OK. Maybe it can be cleared via the OS itself, I don't know.