PDA

View Full Version : Does programming the Propeller work with Parallels Desktop?



Marc Gebauer
01-21-2008, 08:21 AM
I have an Macbook Pro 2.16GHZ (Intel Mac) running Leopard 10.5.1. I·am using Parallels desktop 3.0 build 5584 to run an Windows·XP virtual machine image file. I have an education kit and a demo board, neither of which am I able to program with the Propeller tool.·If I select IDENTIFY HARDWARE, I get a message 'Propeller chip version 1 found on com6'. But if I choose to LOAD RAM or LOAD EEPROM i get the message 'No Propeller chip found on any Com port. Scanned com6.' Per a post I found on this forum I have gone into the device manager in·Windows and set the comm port latency to 1, but no luck.·Does anyone have any·suggestions or information on the subject that would be useful? Thanks


▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔

Mike Green
01-21-2008, 09:10 AM
I use a MacBook with MacOS 10.5.1, Parallels Desktop, and Windows XP all the time for work with the Propeller Tool. Check to make sure you don't have too much running in the background, either on the MacOS side or in Windows. The Windows Updater is the biggest problem. It slows down the MacBook to the point where the time-critical parts of the download fail. My MacBook is slightly slower at 2GHz, but I have 2GB of RAM which helps a little if I want to run other stuff at the same time as Parallels Desktop. I've been able to run the Propeller Tool in the past emulating the PC using GuestPC on a PowerBook, so there's some room for inefficiency. I had to be really careful about other CPU usage there.

Make sure you have the proper drivers (and the latest) installed for the FTDI chipset. I have both Mac and Windows drivers although Parallels uses only the Windows driver as far as I can tell.

Marc Gebauer
01-21-2008, 09:34 AM
Mike,
Tried your suggestions without success. Is there a newer FTDI driver than the one that gets installed with the Propeller Tool ver 1.05.8? I don't do any FTDI com work on the MAC side, so I don't know what driver I would have installed for MAC (if it matters). I also have 2GB of ram, but I have manually set the allocated ram for my Virtual Machine to 768MB. I have read on the Parallels forum that some people have found that the amount of ram allocated for the VM, larger or smaller, can sometimes adversely affect performance. How much ram is your VM using? Also, do you enable Parallels Virtual Memory Preallocation?

▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔

Mike Green
01-21-2008, 09:40 AM
Download the current drivers from FTDI's website (www.ftdichip.com/FTDrivers.htm (http://www.ftdichip.com/FTDrivers.htm)).

My VM is set for only 512MB and the VM preallocation is off.

wastehl
01-21-2008, 11:36 AM
I am running Parallels with both Tiger and Leopard, using the drivers that came with the latest Propeller tool. I have had no problem, save for one time where there as a cpu intensive program running at the same time. Windows updates and anti-virus updates can also cause problems. It would be good to check you USB setup in Parallels Tools to make sure the auto-detect is enabled. It works very well for me, and I generally run a USB scope at the same time. I use both a MacBook and a Mac Mini. I use the same VM setup as Mike...

Forest Godfrey
01-22-2008, 02:45 PM
Some suggestions if installing the drivers doesn't help (and you haven't tried this already)... First, under the Parallels USB preferences, select "Connect USB Devices Automatically". Second, make sure to plug in the Prop USB dongle *after* you have started Windows. Hope that helps!
I've been using it for a few months with Parallels on Tiger running Windows XP.

Marc Gebauer
01-23-2008, 04:02 AM
Well I've tried all the suggestions and NO LUCK!

At first when I updated the 2.0.0.0 driver, which I believe was installed with Propeller Tool 1.05.8, to 2.2.4.0 the programmer started to work, but half way through failed and after that it never tried to worked again. I've looked at the Task Manager processes pane and have no CPU hogs running. CPU usage is at 1 to 3%. I shut off my virus software and microsoft update. I've set Parallels USB preference to connect all usb devices to guest OS.

▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔


Post Edited (Marc Gebauer) : 1/22/2008 8:32:04 PM GMT

Marc Gebauer
01-23-2008, 04:54 AM
Just found out that smaller spin programs with just one added object work! But the spin programs with 3 or 4 objects fail.

▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔

Mike Green
01-23-2008, 05:00 AM
Clearly the Propeller Tool works with similar configurations (and without any fuss). I've had no problems compiling and installing large, complex, multi-object programs. Check your VM memory allocation. The only other suggestions I'd have at this point are:

1) Remove and completely reinstall a freshly downloaded Propeller Tool (V 1.06) and its USB driver.

2) Reinstall Windows in a fresh VM and reinstall the Propeller Tool and its USB driver.

Marc Gebauer
01-24-2008, 01:31 PM
Mike,
I've tried a variety of memory allocations and Un-installing/Reinstalling the FTDI driver/Propeller Tool did not help. I created a second Windows XP virtual machine upon which I·installed the Propeller Tool·and it works. Yay!·Since I can share files between both of my virtual machines,·I have no problem·using a second VM for the Propeller Tool. If I ever figure out how to fix my original VM,·I'll post the fix here.


▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔

Chuck Rice
02-02-2008, 05:13 AM
I am having this same problem. This looks like a design problem with the Propeller serial communications. F7 always works and tells me that I have a propeller connected to COM7. F10 randomly works and it is less likely to work as the program size increases. This is a real bummer as I can never guess if I will be able to program the device or not.

Is the serial protocol available somewhere? -Chuck-

Mike Green
02-02-2008, 05:44 AM
The serial protocol has been documented and there are sample downloading programs written in Python and in Spin.
Look at the "sticky" threads at the beginning of the Propeller Forum for Graham Stabler's Good Thread Index and you'll
find links to these.

stevenmess2004
02-02-2008, 08:05 AM
Chuck, there is a python download script that works on Macs. Here is a link to it http://forums.parallax.com/forums/default.aspx?f=25&m=234296. I currently use PropTool under Crossover and use this to download programs.

Steven

wastehl
02-02-2008, 03:36 PM
There are several dedicated function keys in Parallels, I have had better luck using the drop down menus in the Propeller Tool. In several months of work, however, it has never given me any serious problems. The Mac USB drivers do not enter into the picture. You need the latest drivers from the Propeller download, installed in your VM.