PDA

View Full Version : Debugging Propeller Assembly - Help



Mike G
01-10-2008, 12:33 PM
Does any one have a few pointers when it comes to debugging propeller assembly?

I’ve been messing around with POD 1.2 with the terminal app for a few days and I can’t figure it out. I’m using the AsmDebugDemo.spin that came with the download from the object exchange to experiment.

The instructions say

“After starting the POD you will see two views which are separated by a horizontal split bar. The top view is the code view and the bottom view is the data view.”

I do not see a split horizontal view. I see vertical HEX/ASCII view until I press F12 then I get an Assembly view. F11 does not seem to do anything.

Another instruction says
“The current line in a view is shown highlighted with blue color.”
I’ve got no blue color unless I press F5. But it flashes so fast that I can’t make out what it says. There’s some yellow text too. The best I could make out is an occasional “NC”.

So I keep on pressing F5 to single step hoping that something will pop up at me where I say Oh that’s it!!! No dice so far. It would be helpful if I could determine which line will execute next and what values are in the registers.

I just need someone to help get me on the right track.

Thanks

Ariba
01-10-2008, 03:37 PM
Mike G said...
Does any one have a few pointers when it comes to debugging propeller assembly?


Yes, PASD: http://forums.parallax.com/showpost.php?p=0

Andy

Jim Coleman
01-10-2008, 08:43 PM
Try SimplePropellerAssemblyDebugger SPAD on the object exchange.

Mike G
01-10-2008, 09:23 PM
Thanks Andy and Jim. PASD looks real good. I'll give a shot after work.