PDA

View Full Version : Any way to stop the Propeller tool from scanning my serial ports?



StellanL
01-08-2008, 04:46 PM
Hi everyone.

I normally have many virtual serial ports for a variety of attached hardware.
The Propeller Tools scanning of these often causes conflicts and hangs.
Is there a way to tell it to only use a specified port?

/StellanL

Ale
01-08-2008, 06:47 PM
Sadly, no :-(, other members have asked for it
Maybe a workaround could be to put the propeller in one of the first ports, if that where possible.

Rayman
01-09-2008, 12:04 AM
I wish they would fix this... I find it very annoying. Especially, when I'm having communications issues... It's also a problem with my 3D monitor. It must also use the DTR line trick like Parallax does because the Prop tool toggles my monitor between 2D and 3D mode!

Paul Baker
01-09-2008, 12:56 AM
Its currently being worked on, and I don't have a expected date. Meanwhile Ariba's PropTerminal permits com port selection.

▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔
Paul Baker (mailto:pbaker@parallax.com)
Propeller Applications Engineer
[/url][url=http://www.parallax.com] (http://www.parallax.com)
Parallax, Inc. (http://www.parallax.com)

mosquito56
01-09-2008, 01:14 AM
·Are you using windows? I don't know if linux can support multiple usb ports but I got an idea to throw out.

·Goto systems and remove all your usb drivers. Plug in the prop chip. It should be the first driver now and hopefully will install on comm2 or comm3. Then reinstall all your other stuff and hopefully they will get higher numbers.· I had trouble when I first connected my chip. I disconnected everything and deleted a bad usb from systems. I restarted computer and everything is·working great and·the prop is on comm3.

·As I am not a Windows fan but have to use it, I am not sure this will work but thought I would throw it out there.


Not sure if it matters, I am using windows XP pro.



As I read the following post I realize it is not an uncommon problem. I use very few newer usb devices so this worked for me. Sorry for the inconvience.

▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔▔
Mosquito: An animal which buzzes in your ear and never stops. He may byte you, he may nibble you, but you will know you were bit.


Technologically challenged individual, Please have pity.

Post Edited (mosquito56) : 1/8/2008 8:14:36 PM GMT

Ariba
01-09-2008, 02:47 AM
StellanL

You can try this "Hack" here:

http://forums.parallax.com/showthread.php?p=665707

Andy

Dag Spicer
01-09-2008, 12:51 PM
I seem to be having a similar issues but maybe with a twist?

I use a a PowerBook (Mac) running Parallels (and Win XP under that).

Does anyone know if this has arrangement has worked in the past?

Thanks for any help,

d

Mike Green
01-09-2008, 12:56 PM
Dag,
I use Parallels/WinXP all the time to run the Propeller Tool. It works well.

Ale
01-09-2008, 02:16 PM
mosquito56 said...
I don't know if linux can support multiple usb ports but I got an idea to throw out.


A bit better than windows, of course.



Dag said...
I use a a PowerBook (Mac) running Parallels (and Win XP under that).


That is a bit difficult to believe. Either is a MacBook/Pro (Intel) or you are using VirtualPC (that works on PPC). Parallels is for Intel Macs Only.